vSAN Performance Charts are empty (No information is being displayed)
book
Article ID: 326530
calendar_today
Updated On:
Products
VMware vSAN
Issue/Introduction
Symptoms:
When checking the vSAN - Backend for any of the hosts in the vSAN cluster none of the graphs loads any data. No error messages just blank. You can check this in two places:
Host Level: Web Client > Click on host > Monitor > vSAN - Performance > Backend
Cause
This may be caused by ports not open between ESXi and vCenter.
Additionally, the NTP, vSAN Management (vsanmgmtd), or vCenter services may not be running properly.
The service handshake for the performance service functionally did not properly initiate.
The vCenter version is down rev of the ESXI version
vSAN VASA providers are offline and not working properly
Note: As of version 6.7 or above there should only be one single vSAN VASA provider per cluster instead of per host.
Resolution
To resolve this issue, please check the below steps:
Ensure all the firewall ports required for vSAN are open on the vCenter server. ( Refer to VMware Ports and Protocols )
Make sure that the NTP service is running on all the hosts, with the following command: /etc/init.d/ntpd status.
If the NTP service is not running start it: /etc/init.d/ntpd start.
Workaround: Try to use the following workaround as perhaps the services might be causing the display issue:
Disable and re-enable vSAN Performance Service: Web Client > Click vSAN Cluster > Configure/Manage > vSAN - Services > Performance Service > Edit > Disable it and apply changes > Enable back and apply.
On all Hosts in the Cluster: Restart vSAN management service, SSH into the hosts, and run this command: /etc/init.d/vsanmgmtd restart or stop/start
On the vCenter Machine: Restart Service "VMware Performance Charts" (vmware-perfcharts) with the command: service-control --restart vmware-perfcharts or by restarting the service from the web client
On the vCenter Machine: Restart "VMware vSphere Profile-Driven Storage Service" (vmware-sps) with the command: service-control --restart vmware-sps or by restarting the service from the web client.
On the vCenter Machine: Restart "VMware Virtual SAN Health Service" (vmware-vsan-health) with the command: service-control --restart vmware-vsan-health or restart the service from the web client.
On all Hosts in the Cluster: Restart the vSAN vendor provider, SSH into the hosts, and run this command: /etc/init.d/vsanvpd restart. (Only for hosts below version 6.7)
Check if all VASA providers are Online and Re-scan of them: In the Web client > click vCenter > Configure > Storage Providers > Click "Synchronize Storage Providers". VASA Provider Registration Troubleshooting (49798)
Check if port 8080 (TCP) is open between the ESXI hosts and vCenter. Use nc -z <IP addr> 8080