vSAN Memory congestion on host(s) may result in not seeing the data on the vSAN datastore
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vSAN Memory congestion on host(s) may result in not seeing the data on the vSAN datastore

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Article ID: 326524

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Updated On:

Products

VMware vSAN

Issue/Introduction

Impact/Risks:
VMs fail to power on.
 
Symptoms:
  • We may not be able to see the Files and folders on the vSAN datastore when one or more vSAN cluster nodes experience Memory congestion.
  • VMs residing on the vSAN datastore fails to power on with an Input/Output error.
  • Log messages in vmkernel.log:
    • LSOM: LSOM_ThrowCongestionVOB:3429: Throttled: Virtual SAN node "HOSTNAME" maximum Memory congestion reached.
    • LSOM: LSOM_ThrowCongestionVOB:3429: Throttled: Virtual SAN node "HOSTNAME" maximum Memory congestion reached.


Environment

vSAN 7.*

vSAN 8.*

Cause

This is observed when we have memory congestion on vSAN hosts.

Resolution

  • Put the host into Maintenance Mode with the option of Ensure Data Accessibility.
  • Reboot the host.
  • As a last resort put the host into Maintenance Mode with No Data Migration and then reboot the host.


Note:
Placing a host into Maintenance Mode with No Data Migration risks VMs going inaccessible if FTT=0, or if the only  Active component of the object resides on the host to be placed in to MM. Please ensure we have the data availability before we implement this.

Additional Information