A general system error occurred: PBM error occurred during PreReconfigureCallback: Fault cause: pbm.fault.PBMFault;Error when trying to run pre-provision validation;No VASA Provider for schema namespace (VSAN) found.A general system error occurred: PBM error occurred during PreCreateCheckCallback: Fault cause: pbm.fault.PBMFault ; No VASA Provider for schema namespace (VSAN) found. The storage service is not initialized. Try again later.
/var/log/vmware/sps.log in vCenter: YYYY-MM-DDTHH:MM:SS [pool-3-thread-16] ERROR opId=12c1420e-01-01-01 com.vmware.sps.pbm.impl.ProfileProviderImpl - Error during fetchContentAsString(pbm.fault.PBMFault) {faultCause = null,faultMessage = (vmodl.LocalizableMessage) [(vmodl.LocalizableMessage) {dynamicType = null,dynamicProperty = null,key = com.vmware.pbm.pbmFault.locale,arg = (vmodl.KeyAnyValue) [(vmodl.KeyAnyValue) {dynamicType = null,dynamicProperty = null,key = summary,value = No VASA Provider for schema namespace (VSAN) found.
/usr/lib/vmware-vpx/sps/conf/sms-config.xml file we see the if the parameter is true: <upgradeOngoing>true</upgradeOngoing> /var/log/vmware/upgrade logs.Take a backup/snapshot of the vCenter before proceeding with the steps below :
Open a SSH session to the vCenter.
Go to /usr/lib/vmware-vpx/sps/conf/
Open sms-config.xml file using a file editor (vi).
Look for the following tag :
<!-- To report the current upgrade state. In fresh install, this will always be false.
Note : This is a system controlled parameter and should not be manually edited -->
<upgradeOngoing>true</upgradeOngoing>
Change that value from true to false.
Restart SPS service: vmon-cli -r sps
Logout and login back to vCenter and you should be able to see Storage providers.