vSAN node PSOD with vs_space_mgmt_map_fini in backtrace
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vSAN node PSOD with vs_space_mgmt_map_fini in backtrace

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Article ID: 326415

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Updated On:

Products

VMware vSAN 6.x VMware vSAN 7.x

Issue/Introduction

Symptoms:
vSAN-enabled ESXi hosts may PSOD during shutdown with the following (or very similar) backtrace:
[0x41803950be95]PanicvPanicInt@vmkernel#nover+0x439 stack: 0x0, 0x41803ae5edf8, 0x451afc09bd88, 0x0, 0x1
[0x41803950c3d2]Panic_vPanic@vmkernel#nover+0x23 stack: 0x0, 0x418039521cf1, 0x13, 0x432100000010, 0x451afc09bde0
[0x418039521cf0]vmk_PanicWithModuleID@vmkernel#nover+0x41 stack: 0x451afc09bde0, 0x451afc09bda0, 0x4321e53738a8, 0xf, 0x41803ae5edb8
[0x41803ae3a936][email protected]#0.0.0.1+0x197 stack: 0x4321e4bc4070, 0x4321e4ec40c0, 0x0, 0x41803ae53790, 0x431be252a358
[0x41803ae16dc7][email protected]#0.0.0.1+0x24 stack: 0x4321e4bc4070, 0x41803ae16f22, 0x0, 0x4321e4bc4070, 0x530
[0x41803ae16f21][email protected]#0.0.0.1+0x9e stack: 0x530, 0x0, 0x0, 0x0, 0x0
[0x41803ae16f71][email protected]#0.0.0.1+0x36 stack: 0x0, 0x41803ae1382e, 0x3f7, 0x41803ae53790, 0x4321e4bc4070
[0x41803ae1382d][email protected]#0.0.0.1+0x9a stack: 0x4321e4bc4070, 0x451afc0a3000, 0x45bb9dffaac0, 0x95d28459f2, 0x431be252a310
[0x41803ae98b57][email protected]#0.0.0.1+0x48 stack: 0x431be16d2b68, 0x0, 0x431be16d2b98, 0x431be16d2b88, 0x431be16d2bc0
[0x4180394eb4c2]HelperQueueFunc@vmkernel#nover+0x30f stack: 0x431be16d2b98, 0x431be16d2b88, 0x431be16d2bc0, 0x451afc0a3000, 0x431be16d2b98
[0x418039710dda]CpuSched_StartWorld@vmkernel#nover+0x77 stack: 0x0, 0x0, 0x0, 0x0, 0x0


Environment

VMware vSAN 6.7.x
VMware vSAN 7.0.x

Cause

This is a known issue which has been investigated by vSAN engineering, cause and fix has been determined.

Resolution

Please update the ESXi host to below mentioned releases, which will address the issue. The host can safely be rebooted.
The fix for this issue for vSAN 6.x and 7.x branches are included in ESXi 6.7 P06 and ESXi 7.0 U3c respectively.

https://docs.vmware.com/en/VMware-vSphere/7.0/rn/vsphere-esxi-70u3c-release-notes.html
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ESXi hosts might fail with a purple diagnostic screen during shutdown due to stale metadata
In rare cases, when you delete a large component in an ESXi host, followed by a reboot, the reboot might start before all metadata of the component gets deleted. The stale metadata might cause the ESXi host to fail with a purple diagnostic screen. 

This issue is resolved in this release. The fix makes sure no pending metadata remains before a reboot of ESXi hosts.
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