vSAN Skyline Health fails to load any data on Retest: "ValueError: year 10000 is out of range"
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vSAN Skyline Health fails to load any data on Retest: "ValueError: year 10000 is out of range"

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Article ID: 326410

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:
  • vSAN Skyline Health fails to load any data on RETEST
  • The error "year 10000 is out of range" can be found in vCenter log file /var/log/vmware/vsan-health/vmware-vsan-health-service.log:
2022-04-24T14:07:03.687+01:00 ERROR vsan-mgmt[55064] [VsanVcClusterHealthSystemImpl::queryClusterHealthSummaryInThread opID=9663e91
e] Fail to query cluster health summary year 10000 is out of range
Traceback (most recent call last):
  File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 3379, in queryClusterHealthSummaryInThread
  File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 3987, in _doQueryClusterHealthSummary
  File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 8831, in _generateHealthGroupResult
  File "bora/vsan/health/vpxd/pyMoVsan/VsanHealthHelpers.py", line 3277, in wrapper
  File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 9105, in _generateEncryptionGroupResult
  File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 10567, in _GetKmsConnectionTest
ValueError: year 10000 is out of range
  • Running below date command on vCenter will help to confirm the current timezone set :
# date +"%Z %z"
CEST +0200


Environment

VMware vSAN 7.0.x

Cause

This issue occurs due to incorrect timezone setting on the vCenter Server. 

Resolution

This issue is resolved in VMware vCenter Server 7.0 Update 3f, available at VMware Downloads.

Workaround:
Please follow below steps to workaround the issue :
  • Login to vCenter Appliance Management page at port 5480 (https://<VC_FQDN_or_IP>:5480>)
  • Select the 'Time' tab, edit settings and change the 'Timezone' setting to UTC+0
  • Restart the vsan-health service on vCenter:
# service-control --restart vsan-health