vSAN health check in vSphere Web Client fails with "back end property provider" error
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vSAN health check in vSphere Web Client fails with "back end property provider" error

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Article ID: 326405

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Updated On:

Products

VMware vSAN

Issue/Introduction

This article provides steps to resolve the error back-end property provider when checking vSAN health through the vSphere Web Client.

Symptoms:
  • Checking vSAN health using using the vSphere Web Client fails with the error:
The query execution timed out because of a back-end property provider
'com.vmware.vsphere.client.storage.impl.StoragePropertyProvider' which took more than 120 seconds.
  • In the /var/log/vmware/vsphere-client/logs/vsphere_client_virgo.log file, you see entries similar to:
[ERROR] usage-data-collector-thread   com.vmware.ph.upload.service.UploadServiceImpl  Failed 3 of 3 attempts to get
manifest from VMware server. The reason for the last failure was (enable 'debug' level logging to see the stack trace for every failed 
attempt): org.apache.http.conn.ConnectTimeoutException: Connect to vcsa.vmware.com:443 [vcsa.vmware.com/<IP Address>]
failed: connect timed out. com.vmware.ph.upload.exception.ConnectionException: org.apache.http.conn.ConnectTimeoutException:
Connect to vcsa.vmware.com:443 [vcsa.vmware.com/<IP Address>] failed: connect timed out
  • In the /var/log/vmware/vsan-health/vmware-vsan-health-service.log, you see entries similar to:
INFO vsan-health[PhoneHomeCollector] [VsanPhoneHomeUtil::isVcPhoneHomeEnabled] VC CEIP Enabled Status : True
...
WARNING vsan-health[EventMonitor] [VsanCloudHealthUtil::checkNetworkConnection] Internet is not connected.


Environment

VMware vSAN 6.x

Cause

The issue occurs if there is no Internet connection while Customer Experience Improvement Program (CEIP) is enabled.

Resolution

To resolve the issue:
  • Disable CEIP or connect to internet.
  1. Log in to the vCenter Server instance as a member of [email protected] group by using the vSphere Web Client.
  2. On the vSphere Web Client Home page, under Administration, click Customer Experience Improvement Program.
  3. Click Join to enable the CEIP or Leave to disable the Program.
  •  Or configure Internet connectivity through vSphere Web Client:
                  vSAN-Cluster > Configure > vSAN > General