SSO login message is displayed with wrong formatting in vCenter 7.0.x when using ADFS as identity provider
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SSO login message is displayed with wrong formatting in vCenter 7.0.x when using ADFS as identity provider

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Article ID: 326211

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
When configuring a login message in SSO while using ADFS as the identity provider, when showing the message in the login screen:
  • the line spacing is too small, resulting in lines overlapping
  • any slash ("/") character get a back slash ("\") put in front of it


Environment

VMware vCenter Server 7.0.x

Cause

This is caused by a code error in the handling of the login message.

Resolution

There currently is no resolution.
VMware engineering is aware of this issue. Please subscribe to this article to be informed when a fix is available.

Workaround:
As a workaround to prevent lines from overlapping (to ensure readability), format your login message with lines only as long that no automatic line breaks need to be inserted, and separate these lines with blank lines.

For example, instead of entering this:
To login, please use <username>@domain.name.tld or login directly using the URL https://server.domain.name.tld/ui/login/oauth2

use this:
To login, please use

<username>@domain.name.tldĀ 

or login directly using the URL

https://server.domain.name.tld/ui/login/oauth2

For the additional back slash characters there is unfortunately no workaround as of now.