Backups or quiesced snapshots for a Windows VM fails with "'VssSyncStart' operation failed: IDispatch error #8451 (0x80042303)"
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Backups or quiesced snapshots for a Windows VM fails with "'VssSyncStart' operation failed: IDispatch error #8451 (0x80042303)"

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Article ID: 326187

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • Quiesced Snapshots are failing for a Windows VM.
  • Cloning also fails with the quiescing error.
  • Likewise, 3rd party backups are failing as well.
  • when reviewing the vmware.log of the VM, the following errors can be found:
    YYYY-MM-DDTHH:MM:SSZ In(05) vmx - Msg_Post: Warning 
    YYYY-MM-DDTHH:MM:SSZ In(05) vmx - [msg.snapshot.quiesce.vmerr] The guest OS has reported an error during quiescing.
    YYYY-MM-DDTHH:MM:SSZ In(05)+ vmx - The error code was: 5
    YYYY-MM-DDTHH:MM:SSZ In(05)+ vmx - The error message was: 'VssSyncStart' operation failed: IDispatch error #8451 (0x80042303)

 

  • The Windows Application Event log in the guest OS holds error events ID 8193 from VSS similar to the one below:
    Log Name:      Application
    Source:        VSS
    Date:          DD/MM/YYYY HH:MM:SS
    Event ID: 8193 Task Category: None Level: Error Keywords: Classic User: N/A Computer: redacted Description: Volume Shadow Copy Service error: Unexpected error calling routine CLSIDFromString({564d7761-7265-2056-5353-000000010000}). hr = 0x80070002, The system cannot find the file specified. . Operation: Unregistering Provider Context: Provider ID: {564d7761-7265-2056-5353-2050726f7669} Event Xml: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="VSS" /> <EventID Qualifiers="0">8193</EventID> <Level>2</Level> <Task>0</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="YYYY-MM-DDTHH:MM:SS.xxxxxxZ" /> <EventRecordID>7090</EventRecordID> <Channel>Application</Channel> <Computer>redacted</Computer> <Security /> </System> <EventData> <Data>CLSIDFromString({564d7761-7265-2056-5353-000000010000})</Data> <Data>0x80070002, The system cannot find the file specified. </Data> <Data> Operation: Unregistering Provider Context: Provider ID: {564d7761-7265-2056-5353-2050726f7669}</Data>
    </EventData> </Event>



Cause

This issue occurs when a stale registry key for the VMware Snapshot Provider is left in Windows registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Providers\{564d7761-7265-2056-5353-2050726f7669}

This key should only exist while a quiesced snapshot is being created or consolidated, but not before or after.

Resolution

To resolve this issue, follow the steps below:

  • Connect to the Windows  guest OS of the affected virtual machine, run:   vssadmin list providers
  • Check if Provider 564d7761-7265-2056-5353-2050726f7669 is listed.
  • Connect to the Windows registry in the guest OS of the affected virtual machine using the regedit utility
  • Export the registry branch HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Providers as backup
  • In the branch, find the registry key {564d7761-7265-2056-5353-2050726f7669}
  • Delete the key
  • Exit regedit and reboot the virtual machine


Once these steps have been taken, please try taking a quiesced snapshot of the virtual machine to confirm the solution.

 

Additional Information