'The operation has timed out' when performing Amazon AWS endpoint data collection
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'The operation has timed out' when performing Amazon AWS endpoint data collection

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Article ID: 326168

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
Amazon endpoint data collection is failing to complete, or shows blank values for 'last completed' and 'status'. 

Messages like the following are seen within the DEM worker logs.

Workflow 'AmazonEC2EndpointDataCollection' failed with the following exception:
System.Data.Services.Client.DataServiceTransportException: The operation has timed out ---> System.Net.WebException: The operation has timed out


Environment

VMware vRealize Automation 7.1.x
VMware vRealize Automation 7.0.x
VMware vRealize Automation 7.4.x
VMware vRealize Automation 7.5.x
VMware vRealize Automation 7.2.x
VMware vRealize Automation 7.3.x

Cause

This issue can occur when a region containing many images is removed from the vRealize Automation (vRA) fabric group. On the next data collection, vRA attempts to delete these records for the removed AWS region. If there are enough objects, the data collection times out and fails.

Resolution

This issue is resolved in vRealize Automation 7.6.

Workaround:
The attached hotfix changes the behavior to remove these objects in batches so the timeout is not encountered.

You can re-enable the region in the vRA fabric group to immediately resolve data collection issues.

For a permanent solution, install vRA_73_HF_2234140 attached to this KB article. Installation and rollback instructions are included in the .zip archive.

Attachments

vRA_73_HF_2234140.zip get_app