vCenter Cloud Account data collection fails if UTF_8 characters are used in a password which may lock the service account
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vCenter Cloud Account data collection fails if UTF_8 characters are used in a password which may lock the service account

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Article ID: 326155

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • The vRealize Automation admin can configure a vCenter cloud account but after saving the cloud account, data collection would fail with error
    The connection with vAPI endpoint cannot be established. Please make sure the vAPI endpoint is running in the vCenter
  • If username used in vCenter cloud account configuration is set to lock out on certain login failure attempts, the account would be locked out.
  • provisioning-service-app.log contains errors similar to
    POST https://vcenter-hostname/rest/com/vmware/cis/session]: Request failed due to status code 401. Retrying..
Failed to connect to vCenter: Error: Cannot complete login due to an incorrect user name or password.


Environment

VMware vRealize Automation 8.6.x
VMware vRealize Automation 8.4.x
VMware vRealize Automation 8.3.x
VMware vRealize Automation 8.5.x
VMware vRealize Automation 8.2.x

Cause

vRealize Automation can send incorrectly encoded Authorization Headers to the vAPI when there are UTF_8 characters in the password.

Resolution

VMware is aware of this issue.

A resolution for this issue is being evaluated for inclusion in a future release.

Workaround:
To work around this issue, use a vCenter account that does not contain UTF_8 characters in the password.

Additional Information

Impact/Risks:
Service accounts used by the Cloud account configuration may become locked out if UTF_8 characters are used in the password.