Inventory sync in vRSLCM fails with LCMVIDMIMPORT0011 when syncing VMware Identity Manager
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Inventory sync in vRSLCM fails with LCMVIDMIMPORT0011 when syncing VMware Identity Manager

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Article ID: 326115

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Updated On:

Products

VMware VMware Aria Suite

Issue/Introduction

Address the LCMVIDMIMPORT0011 error received when performing an inventory sync against vIDM in vRSLCM.


Symptoms:
  • While running the inventory sync for VMware Identity Manager (vIDM) from VMware Lifecycle Manager (vRSLCM), you see the following error:
    LCMVIDMIMPORT0011

image.png

  • The following log in vRSLCM /var/log/vrlcm/vmware_vrlcm.log file contains a communication error similar to the below
2023-02-23 17:10:16.169 INFO [pool-3-thread-39] c.v.v.l.p.a.s.Task - -- Injecting task failure event. Error Code : 'LCMVIDMIMPORT0011', Retry : 'true', Causing Properties : '{ CAUSE :: hostNameOrIP === vidmSystemAdminPassword }'
com.vmware.vrealize.lcm.vidm.common.exception.VidmVerifySystemAdminPasswordException: Error while getting login token.Unable to verify the systemAdminPassword for the host FQDN_OF_VIDMConnect to FQDN_OF_VIDM:8443 [FQDN_OF_VIDM/IP_OF_VIDM] failed: Connection timed out (Connection timed out)
 at com.vmware.vrealize.lcm.vidm.driver.helpers.VidmImportUtil.verifySystemAdminPassword(VidmImportUtil.java:1069) ~[vmlcm-vidmplugin-driver-8.6.0-SNAPSHOT.jar!/:?]


Environment

VMware vRealize Suite Lifecycle Manager 8.x
VMware Identity Manager 3.3.x

Cause

The following error LCMVIDMIMPORT0011 is generated in two scenarios:

  1. The passwords are expired.
  2. There are communication issues between vRSLCM and vIDM.

Resolution

1. Error caused due to password failure:

2. Error caused due to communication failure:

  • Validate /var/log/vrlcm/vmware_vrlcm.log contains the following
    failed: Connection timed out (Connection timed out)
  • From the VRLCM console, run the following command:
    curl -v https://FQDN_OF_VIDM:8443
    • Validate the above command returns a connected response similar to the below screenshotimage.png
  • If the above curl command shows an error, validate if vRSLCM is able to communicate with vIDM over port 8443.
    • Once the port has been opened or vIDM services restored, perform the inventory sync again.
    • If the inventory sync fails again, please open a support request with Global Support.


Additional Information

https://kb.vmware.com/s/article/2149950

 


Impact/Risks:
  • Inventory sync fails against vIDM
  • You are no longer able to manage vIDM from vRSLCM