Inventory sync in Aria Suite Lifecycle fails with LCMVIDMIMPORT0011 when syncing VMware Identity Manager
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Inventory sync in Aria Suite Lifecycle fails with LCMVIDMIMPORT0011 when syncing VMware Identity Manager

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Article ID: 326115

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • While running the inventory sync for VMware Identity Manager (vIDM) from Aria Suite Lifecycle, it prompts the following error:
    LCMVIDMIMPORT0011

  • The following log in the Aria Suite Lifecycle /var/log/vrlcm/vmware_vrlcm.log file contains a communication error similar to the below
2023-02-23 17:10:16.169 INFO [pool-3-thread-39] c.v.v.l.p.a.s.Task - -- Injecting task failure event. Error Code : 'LCMVIDMIMPORT0011', Retry : 'true', Causing Properties : '{ CAUSE :: hostNameOrIP === vidmSystemAdminPassword }'
com.vmware.vrealize.lcm.vidm.common.exception.VidmVerifySystemAdminPasswordException: Error while getting login token.Unable to verify the systemAdminPassword for the host FQDN_OF_VIDMConnect to FQDN_OF_VIDM:8443 [FQDN_OF_VIDM/IP_OF_VIDM] failed: Connection timed out (Connection timed out)
 at com.vmware.vrealize.lcm.vidm.driver.helpers.VidmImportUtil.verifySystemAdminPassword(VidmImportUtil.java:1069) ~[vmlcm-vidmplugin-driver-8.6.0-SNAPSHOT.jar!/:?]

Environment

Aria Suite Lifecycle 8.x
VMware Identity Manager 3.3.x

Cause

The following error LCMVIDMIMPORT0011 is generated in two scenarios:

  1. The passwords have expired.
  2. There are communication issues between Aria Suite Lifecycle and vIDM.

Resolution

1. Error caused due to password failure:

2. Error caused due to communication failure:

  • Validate /var/log/vrlcm/vmware_vrlcm.log contains the following
    failed: Connection timed out (Connection timed out)
  • From the Aria Suite Lifecycle console, run the following command:
    curl -v https://FQDN_OF_VIDM:8443
    • Validate that the above command returns a connected response similar to the below screenshot

  • If the above curl command shows an error, validate if Aria Suite Lifecycle is able to communicate with vIDM over port 8443.
    • Once the port has been opened or vIDM services restored, perform the inventory sync again.
    • If the inventory sync fails again, please open a support request with Global Support.

Additional Information

VMware Workspace One Access and IDM, resetting admin and configurator passwords


Impact/Risks:

  • Inventory sync fails against vIDM
  • No longer able to manage vIDM from Aria Suite Lifecycle.

The error code will be also returned when the vIDM node is removed in Aria Lifecycle portal directly, need to manually remove the node further in vIDM admin portal refer to below doc:

https://techdocs.broadcom.com/us/en/vmware-cis/other/vmware-identity-manager/3-3/idm-windows-installation-map-3-3/deploying-vmware-identity-manager-on-windows-servers/configuring-failover-and-redundancy-in-a-single-data-center-windows/removing-a-workspace-one-access-node-from-a-cluster/remove-the-workspace-one-access-node-from-the-cluster.html