"Mismatched component versions" warning is reported within the vRealize Automation Management Interface after a Cumulative Update
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"Mismatched component versions" warning is reported within the vRealize Automation Management Interface after a Cumulative Update

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Article ID: 326098

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • After applying a vRealize Automation cumulative patch you may see similar warnings within the vRealize Automation VAMI Cluster tab: 
Node vra-Web-1.rainpole.local has mismatched component versions!
Node vra-Mgr-1.rainpole.local has mismatched component versions!
Node vra-Mgr-2.rainpole.local has mismatched component versions!
Node vra-DEMW-1.rainpole.local has mismatched component versions!
Node vra-DEMW-2.rainpole.local has mismatched component versions!


Environment

VMware vRealize Automation 7.5.x
VMware vRealize Automation 7.6.x
VMware vRealize Automation 7.4.x

Cause

This issue occurs due to the dynamic link library (*.dll) files and executable (*.exe) files patched to a newer version as part of the cumulative update.

These warning are expected and do not indicate an issue in the following patch versions:
  • 7.4 HF1 to 7.4 HF13
  • 7.5 HF1 to 7.5 HF8 
  • 7.6 HF1

Resolution

A number of triggers for this issue are resolved in vRA 7.5 HF9 and 7.6 HF2 and later versions. 

The component version information is read from the windows registry on the iaas servers and then relayed back to the VAMI by the Management agent component.

If the issue persist after applying the relevant patch then please raise a support request for further assistance.

In certain circumstances these registry key entries under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\VMware, Inc.\ need to be cleaned up manually.

Procedure: 
1. Login to the IAAS server with the alert in the VAMI.
2. Open Registry Editor
3. Navigate to  C: \> reg query "HKEY_LOCAL_MACHINE \ SOFTWARE \ WOW6432Node \ VMware, Inc. \ VMware vCloud Automation Center Agents "and removed the records with no type and name attributes.

Note: In General Availability (GA) environments - such warnings are indicative of a version mismatch and should be investigated. In such cases, please contact VMware Support. For more information, see Filing a Support Request in Customer Connect (2006985).