vRealize Automation installation/upgrade fails at the Java version check
search cancel

vRealize Automation installation/upgrade fails at the Java version check

book

Article ID: 326091

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Java update 1.8, versions u192, u201, and u202, are incompatible with 7.3 - 7.5¬†installations.
  • vRealize Automation installation or upgrade fails at the Java version check or at the database upgrade/installation phase with an error similar to:
"Java version 1.8 update 181 or higher (64-bit) must be installed, the environment variable JAVA_HOME must be set to the Java install folder, and %JAVA_HOME%\bin\java.exe must exist."


Environment

VMware vRealize Automation 7.5.x
VMware vRealize Automation 7.4.x
VMware vRealize Automation 7.3.x

Cause

Java 1.8 updates versions: u192, u201 and u202 can cause problems with the IaaS Database installation if the automatic prerequisite fixes have not been applied.

A change in version metadata that the IaaS prerequisite checker verifies was impacted due to a Java bug identified in these versions.

This issue does not affect upgrades to 7.6 even if one of these Java 1.8 updates have been installed.

Resolution

To resolve this issue, use java version 1.8 u191 or u211+.

Note:  You may install 7.x with the automatic prerequisite fixes enabled to install the older Java version 1.8 u191 on the IaaS machines.  After the installation completes, the newer Java version 1.8 u201 or u202 can be installed manually.

Note:  Fixes for this issue have been applied to vRealize Automation 7.6 GA, 7.5 Patch 8 and 7.4 Patch 13.