Orchestrator server additional redirect when logging into Orchestration UI instead of redirecting to Orchestration UI post upgrade to 8.16.x
search cancel

Orchestrator server additional redirect when logging into Orchestration UI instead of redirecting to Orchestration UI post upgrade to 8.16.x

book

Article ID: 326021

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
There is an additional redirect to the VMware Aria Automation Orchestrator 8.x server after upgrading the external or standalone Automation Orchestrators instead of redirecting directly to the product UI.

Environment

VMware Aria Automation Orchestrator 8.16.x

Cause

The redirect address has not been updated after Orchestrator was converted to use the PKCE flow for authentication against Aria Automation.

Resolution

VMware is aware of this issue. A fix is being considered for inclusion in a later release. See the workaround below for additional information.

Workaround:

Prerequisites

  • You have root username and password.
  • You have access to a SSH client or PuTTy.

Procedure

  1. SSH into the Automation Orchestrator appliance as root.
  2. Run the below shell script:
    /opt/scripts/update_o11n_ui_client.sh
Note: The script will require the administrator's username and password
  1. Redeploy the services:
    /opt/scripts/deploy.sh