Console-logs for extensibility-service-app are not rotated
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Console-logs for extensibility-service-app are not rotated

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Article ID: 325986

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
When running the below command, only one log file will be listed without any rotations and will be over 200MB.
ls -la /var/log/services-logs/prelude/extensibility-service-app/console-logs/


Environment

VMware vRealize Automation 8.11.x

Cause

Log rotation configuration is missing for extensibility service console logs.

Resolution

This issue is resolved in VMware vRealize Automation 8.11.2.

See the Workaround section below for additional information.

Workaround:

Prerequisites

  • Please take simultaneous non-memory snapshots of each virtual appliance(s) in the cluster.
  • You have access to root user and password
  • You have SSH or console access to each virtual appliance.

Procedure

  1. SSH / PuTTy into one vRA virtual appliance in the cluster
  2. Run the following command to patch the necessary configurations:
    base64 -d <<< '/Td6WFoAAATm1rRGAgAhARwAAAAQz1jM4AdUAuFdABGIQkY99Bhqpmevep9yj5xO8pryhHT59+C7N+08qDLAVQaIosVgsg/cxpSwloVH1G+TqJAppE4EfGNXWJ71y4KvBE63IMtuFbN2Fd01mNysO2XG8cScnTy4mNn3T6krxBnvqTsm4DrM48YfvYaJW4b4kgJB1nhmQG7BibQrYz+rCcUVZEAorcq/Uu0LLLL6xi/o22iqUBIxHFqEe7SpvwiGGP7Hg4qNCy5f3+hFADF7JwRhTpT2+vR3G1wl1gJgQog2ItZTuuvyWiogViT3ULLPIWEISO0nmd3+XgiY5JDaqiLtJqvFkzECq6C28SoRVOXwShjvKojEXSS9iVLA3R+tF5jRitxf1DdbYdD0H/ZibXq0n+ya4WIZxgtU53rw7fIX/TW0hY5yZVia4ntb/RK3Fudh9Yy3KtOfYq78pMZYAw+ee1MG9WNTHNEmiXkVXqkrKzMwVIYoG+WNHoprIgQajHlEvP+7ep2iBxpGneV3uv/pPEA4L2+uVT59w/2tY0rtIKkIxZ4waVP5kNZ1/aBF9U+ZMHBkyQxsA/gEmzndXvCfLFdz9gSZRNPnnAh61rZwdKX/pwHqWK/o1kISDBjRtxl0/z2U+qPHWMgeYSRGBEdK2DPlDaSQQ1MdxcfWOA1kmgTfXkMOX6+mFPbIAJa4F4TbJvgfwZNc+hHpc6/LoVaWTI279sj6Ih5MIyqvXdvOt153vN3YBd0ea2sH03Ace3Zgj25ss2iYuiKfOXNE3hlTh+mfbXIbp67AXKv6p6R3jrp3PvrQoLETnb2eT6e6XXYtc+1kkO/6bxmFpi+r8faCE4KSjfJzeIGpj+5HQ/iFK/OFtNJPHY/OYwO3ihw1ysuZDljWRfqMXhXWzde/NmwOi1AYo9CC32FSySobxbNaLt+JwXlRs5i02RScfFMN83PNrQV6I0uKLdjGr4nM6T82mI2ZC2Jc/xP8YXoDV0SuWaZWl3IXr7i5QJInW/OpAAAAAFjaMUEFXGkrAAH9BdUOAADLNa25scRn+wIAAAAABFla' | xz -d | bash -

Step # 2 Command Failure

  1. If the Step #2 from the Procedure above fails, use these instructions to revert to the old configurations or revert to the snapshots taken at the beginning of this procedure.
  2. Recover the old logging configuration which was backed up at /data/patch-backup/extensibility-service-logrotate-timestamp/logging.yaml.
    1. Make sure to replace timestamp with the actual timestamp of the existing file in the command below:
      vracli cluster exec -- mv /data/patch-backup/extensibility-service-logrotate-timestamp/logging.yaml /opt/charts/extensibility-service/templates/logging.yaml
  3. Re-apply the old configmap to Kubernetes:
    kubectl -n prelude apply -f /opt/charts/extensibility-service/templates/logging.yaml
  4. Update the logrotate configs to the originals:
    vracli cluster exec -- bash -c 'PYTHONPATH=/opt/python-modules python3 /opt/scripts/logging/update_logrotate_configs.py'


Additional Information

Impact/Risks:
Extensibility service console logs will grow with time and will not be compressed or cleaned up.