When configuring outbound Email Server you receive the message 'Test connection failed'
search cancel

When configuring outbound Email Server you receive the message 'Test connection failed'

book

Article ID: 325912

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
When configuring Email Servers in vRealize Automation 8.0 you receive the following symptoms:
  • Error message in the user interface is 'Test connection failed'.
  • Error messages in the catalog-service-app logs show similar to:  
subject='Email Configuration Test',
recipients=[Recipient{name='null', address='<userID>', type=To}]
  • Error messages in the catalog-service-app logs show similar to:
org.simplejavamail.mailer.MailerException: Invalid TO address: Email{
	id=null
	fromRecipient=Recipient{name='<Administrator Name>', address='<[email protected]>', type=null},
	replyToRecipient=null,
	bounceToRecipient=null,
	text='null',
	textHTML='<!DOCTYPE html>


Environment

VMware vRealize Automation 8.x

Cause

This is caused by a failure in the querying logic that is attempting the connection.

Resolution

VMware is aware of this issue and is working on a solution.

There is no workaround at this time.