402 Error It appears that you subscription has expired message when logging into VMware Aria Automation
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402 Error It appears that you subscription has expired message when logging into VMware Aria Automation

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Article ID: 325911

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

The Aria Automation license needs to be updated.


Symptoms:
  • You are using VMware Aria Automation (formerly vRealize Automation) 8.x.
  • When you login, the landing page has the following message:
    402 Error
    
    It appears that your subscription has expired.
    Your workloads are still available. Contact your
    Account Manager or Customer Success Manager to
    renew so that you can log in and keep working


Environment

VMware vRealize Automation 8.x

Cause

The Aria Automation license is expired or has not been applied correctly.

Resolution

Update the Aria Automation license using VMware Aria Suite Lifecycle (formerly vRealize Suite Lifecycle Manager) 8.x.

If the update fails, proceed to the Workaround section below.


Workaround:

To resolve the issue manually update the Aria Automation license using vracli commands.

  1. SSH to the Aria Automation appliance primary node and run the following commands
    1. Retrieve the current expired license
      vracli license
    2. Remove the Expired / Faulty License
      vracli license remove License_Key
    3. Add new valid License
      vracli license add License_Key
  2. Trigger an Inventory Sync of the Aria Automation environment in Aria Suite Lifecycle
  3. Perform a Re-trust of Aria Automation with Identity Manager via Aria Suite Lifecycle
  4. Restart the Aria Automation services as final validation step
    1. Stop services
      • Version 8.5 and below
        /opt/scripts/deploy.sh --onlyClean
      • Version 8.6 and above
        /opt/scripts/deploy.sh --shutdown
    2. Start services
      /opt/scripts/deploy.sh


Additional Information

 

 


Impact/Risks:

The Aria Automation portal is not accessible.