402 Error It appears that you subscription has expired or about to expire message when logging into VMware Aria Automation/ Orchestrator
search cancel

402 Error It appears that you subscription has expired or about to expire message when logging into VMware Aria Automation/ Orchestrator

book

Article ID: 325911

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

The Aria Automation/Orchestrator license needs to be updated.


Symptoms:

  • You are using VMware Aria Automation/Orchestrator (formerly vRealize Automation) 8.x.
  • When you log in, the landing page has either of the following messages:

402 Error It appears that your subscription has expired. Your workloads are still available. Contact your Account Manager or Customer Success Manager to renew so that you can log in and keep working

Or 

Your subscription expires in x days. Please Contact your Account Manager or Customer Success Manager to renew your license

  • NOTE: Depending on the version of Aria Automation/Orchestrator, the Banner may present with a different message.
  • In 8.18, the banner is either of the following: 
    "There is no valid subscription in the system. Please contact your Account Manager or Customer Success Manager to add a vCenter cloud account with a valid VCF subscription."
  • "Your subscription expires in x days. Please Contact your Account Manager or Customer Success Manager to renew your license"

Environment

  • VMware Aria Automation 8.x
  • VMware Aria Automation Orchestrator 8.x

Cause

The Aria Automation license is expired or has not been applied correctly.

Resolution

  • Update the Aria Automation license using VMware Aria Suite Lifecycle 8.x. 

    If the update fails, proceed to the Workaround section below.
  • Workaround:
    • To resolve the issue manually update the Aria Automation/Orchestrator license using vracli commands.
    • Take appropriate snapshots before applying the below steps. 
    • SSH to the Aria Automation/Orchestrator appliance primary node and run the following commands
      1. Retrieve the current expired license
        vracli license
      2. Remove the Expired / Faulty License
        vracli license remove License_Key
      3. Add new valid License
        vracli license add License_Key
    • Trigger an Inventory Sync of the Aria Automation/Orchestrator environment in Aria Suite Lifecycle
    • Perform a Re-trust of Aria Automation/Orchestrator with the Identity Manager via Aria Suite Lifecycle
    • Restart the Aria Automation/Orchestrator services as the final validation step
      1. Stop services
        • Version 8.5 and below
          /opt/scripts/deploy.sh --onlyClean
        • Version 8.6 and above
          /opt/scripts/deploy.sh --shutdown
      2. Start services
        /opt/scripts/deploy.sh

Additional Information

Impact/Risks:

The Aria Automation portal is not accessible.