Unable to login to a vRealize Automation tenant portal with domain accounts: "OutOfMemoryError: GC overhead limit exceeded"
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Unable to login to a vRealize Automation tenant portal with domain accounts: "OutOfMemoryError: GC overhead limit exceeded"

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Article ID: 325902

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • By default, only 18GB of total memory is allocated to each vRealize Automation appliance node.
  • This memory is shared between vRealize Automation, VMware Identity Manager (vIDM) and other components internally.
  • The amount of Java heap assigned to vIDM in this scenario is 4GB. In certain circumstances (large AD environments) this is not sufficient.
  • The heap assigned to the vIDM component is controlled dynamically based on how much memory is assigned to the appliance at the machine level.

Symptoms:

  • Users are unable to login to the tenant portal using domain accounts.
  • Local accounts are not impacted.
  • The following message is seen within horizon.log:
2018-08-29 09:29:17,539 ERROR (tomcat-http--18) [-;-;127.0.0.1;] com.vmware.horizon.rest.exception.resolver.AbstractHorizonHandlerExceptionResolver - Exception while invoke REST API:https://FQDN/SAAS/API/1.0/REST/system/healthorg.springframework.web.util.NestedServletException: Handler dispatch failed; nested exception is java.lang.OutOfMemoryError: GC overhead limit exceeded



Environment

VMware vRealize Automation 7.x

Cause

The vIDM components responsible for Authentication & Authorization have a resource constraint that eventually leads to Java out of memory errors.

Resolution

To increase the memory, see the Add Memory to Directories Management section of the relevant vRealize Automation version(s) official documentation.