Day 2 XaaS action fails with Unable to load resource with ID
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Day 2 XaaS action fails with Unable to load resource with ID

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Article ID: 325890

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • You are using vRealize Automation 7.6 Patch 20
  • You submit a Day 2 XaaS action and it fails with a message similar to
    Unable to load resource with ID XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXX from Service Catalog


Environment

VMware vRealize Automation 7.x

Cause

Expired user principals are not refreshed when /tmp/vra-upgrade-on.txt is identified on a node in the cluster.

Resolution

VMware is aware of this issue.  There is currently no resolution for this issue.  See the workaround below for more information.

Workaround:
  1. SSH into each appliance in the cluster
  2. Remove the following file /tmp/vra-upgrade-on.txt if it exists on any appliance in the cluster
  3. Identify the users from the allcatalina.out log.
    1. The below log entry is an example to assist in identifying which user 
      allcatalina.out:[UTC:2021-05-13 01:00:24,517 Local:2021-05-13 01:00:24,517] vcac: [component="cafe:catalog" priority="INFO" thread="tomcat-http--5" tenant="vsphere.local" context="1L8AZtlk" parent="" token="1L8AZtlk"] com.vmware.vcac.catalog.suite.impl.AuthenticationServiceGatewayImpl.canUseCachedPrincipal:305 - Principal [Name="FirstName LastName" PrincipalId = "[email protected]" TenantName="vsphere.local" Type="USER"] : Not refreshing expired principal as upgrade is in progress
      
  4. Update the database to refresh the last sync column for the user identified in the allcatalina.out above
    update cat_principal set last_sync = now() where ref = '[email protected]';


Additional Information

Impact/Risks:
Validate there is a recovery point with a snapshot (temporary) or a back solution according to vRA 7.x product documentation, as there are manual database edits included in these instructions.