VMware vCloud Automation Center Service fails to start in vRealize Automation 7.x
search cancel

VMware vCloud Automation Center Service fails to start in vRealize Automation 7.x

book

Article ID: 325884

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

  • VMware vCloud Automation Center Service fails to start after applying Windows KB3197874 patch on Windows 2012 R2 Server.
  • In the Repository.log file, you see entries similar to:

    [UTC:2016-11-14 06:29:47 Local:2016-11-14 19:29] [Error]: [sub-thread-Id="34" context token] System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileLoadException: Could not load file or assembly 'System.Web.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

  • In the Windows Application/Events logs, you see entries similar to:

    WebHost failed to process a request.
    Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/34766169
    Exception: System.ServiceModel.ServiceActivationException: The service '/Repository/Data/ManagementModelEntities.svc' cannot be activated due to an exception during compilation. The exception message is: Could not load file or assembly 'System.Web.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040). ---> System.IO.FileLoadException: Could not load file or assembly 'System.Web.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Environment

VMware vRealize Automation 7.x

Cause

This issue is caused because of Microsoft Monitoring Agent version: 8.0.10918.0.

Microsoft Monitoring Agent version: 8.0.10918.0 gets installed as part of the November, 2016 Security Monthly Quality Rollup for Windows Server 2012 R2 (KB3197874) patch.

Resolution

To resolve this issue, use one of these options:
  • Replace the Microsoft Monitoring Agent to a version earlier to 8.0.10918.0.
  • Restore the IaaS server to a state prior to the Microsoft KB3197874 patch.
  • Remove the Microsoft Monitoring Agent.
  • Install the Microsoft Monitoring Agent 8.0.10918.0 with the parameter NOAPM=1. For more information, see ​Reinstalling your SCOM agents with the NOAPM switch.
    msiexec.exe /i MOMagent.msi NOAPM=1

Note: It is observed that the issue is only reported if you have applied MS updates from November 2016. To mitigate the issue, VMware recommends applying the latest MS updates.