Login page loads indefinitely when in a vRealize Automation 7.x High Availability cluster
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Article ID: 325862
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Updated On:
Products
VMware Aria Suite
Issue/Introduction
Symptoms:
- vRealize Automation is running in an high availability (HA) cluster with replica / secondary nodes as active
- Users attempting to log into vRealize Automation are met with a spinning wheel and cannot access the application
- Messages similar to the following below found in catalina.out:
2017-04-10 15:40:38,570 vcac: [component="cafe:shell" priority="WARN" thread="tomcat-http--22" tenant="vsphere.local" context="" parent="" token=""] com.vmware.vcac.authentication.http.oauth.WebOAuthAuthenticationFilter.handleException:120 - Authentication request for '/vcac/' failed with: Redirect doesn't match the original requestor. Possible CSRF attack. State: B5CDA6322F61F16067DBDAAD262C85F5; Session id: 8A45B837EB98E8EBBE5BFBBE92001B08
Environment
VMware vRealize Automation 7.x
Cause
Session persistence settings on the load balancer are not properly configured according to VMware provided load balancing documentation.
Resolution
See "Related Information" in this article for links to load balancing documentation.
Ensure valid persistence settings are configured.
Additional Information
vRealize Automation 7.x Load Balancing documentation:
Impact/Risks:
Failure to configure the load balancer with proper session persistence will lead to inconsistent product behavior
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