Manager Service fails to become active when all Manager Service nodes have been down for over 23 days.
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Manager Service fails to become active when all Manager Service nodes have been down for over 23 days.

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Article ID: 325854

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Manager Service fails to become active when all MS nodes have been down for over 23 days.
  • The Manager Service All.log file contains errors similar to the following:
[UTC:2019-04-14 19:23:31 Local:2019-04-14 12:23:31] [Error]: [sub-thread-Id="6" context="" token=""] Failed to parse ping info. Details: System.Data.SqlClient.SqlException (0x80131904): The datediff function resulted in an overflow. The number of dateparts separating two date/time instances is too large. Try to use datediff with a less precise datepart.


Environment

VMware vRealize Automation 7.x

Cause

The error is caused by the difference of time since the last active node has been alive being too great--along with the high precision set by the database calculation logic of the automatic failover process.

Resolution



Workaround:
  1. Log into the IaaS MS SQL database and execute the following query:
DELETE FROM dbo.ManagerServiceNode
  1. Restart the Manager Service