Actions fail with error urllib3 v2.0 only supports OpenSSL 1.1.1+
search cancel

Actions fail with error urllib3 v2.0 only supports OpenSSL 1.1.1+

book

Article ID: 325850

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • ABX python actions fail when not specifying a version when using requests¬†or urllib3¬†dependencies because the latest version of urllib3 expects OpenSSL 1.1.1+.
  • You encounter an error message similar to the below example:
    urllib3 v2.0 only supports OpenSSL 1.1.1+, currently the 'ssl' module is compiled with OpenSSL 1.0.2zg-fips


Environment

VMware Aria Automation 8.12.x

Cause

Importing requests module will result in action failure because the latest version of requests is dependent on urllib3 v2 and urllib3 v2 expects OpenSSL 1.1.1+.

Resolution

VMware is aware of this issue and a fix for this issue is being considered for inclusion in a future release.

Workaround:
When using 'requests' or 'urllib3' as dependencies, please specify a version. For example, the latest version of requests, that is compatible with openSSL 1.0.2zg-fips, is 2.29.0. For urllib3, please use version < 2.

Example: The below is a working example using requests 2.28.1 and urllib3 1.26.15:
image.png

Additional Information

Impact/Risks:
Any new python functions with 'requests' or 'urllib3' without a specified version provided as dependencies to be installed.