Unable to collect data from vCenter adapter in Aria Operations
search cancel

Unable to collect data from vCenter adapter in Aria Operations

book

Article ID: 325764

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

The purpose of this article is to explain how to restore connectivity between vCenter endpoints and Aria Operations for successful collection of metrics.

Symptoms:
  • Metrics are not being collected from vCenter.
  • Dashboards are missing metrics.
  • The Alarm Bell icon shows vCenter Object down error.
  • In Data Sources - Integrations - Accounts - vCenter the Status of the adapter instance is Warning.
  • Hovering over this Warning status you will receive a message similar to: 
    • Certificate validation failed
  • There will be Administrative Alerts similar to:
    • Adapter instance Object is down
    • Objects are not receiving data from adapter instance


Environment

VMware vRealize Operations 8.6.x

Cause

  • Connectivity has failed between vCenter and Aria Operations due to expired or renewed vCenter certificate.

Resolution

  • On the left pane, click Data Sources - Integrations
  • Select the particular adapter and select Edit.
  • Click Validate Connection.
  • A prompt comes up asking the user to import the associated certificate. Click OK.
  • Save the configuration.
  • Stop and Start collection on the adapter.


Additional Information



Impact/Risks:
Take snapshots of each of the vRealize Operations nodes before performing any maintenance activity.
See How to take a Snapshot for more information.