"The name '<VM name>' already exists." error when reattaching a disk after expansion.
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"The name '<VM name>' already exists." error when reattaching a disk after expansion.

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Article ID: 325650

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Reattaching a disk to the virtual machine fails with the error:

[UUID ] null - The name '<VM name>' already exists.

  • There is no VM present in the Cloud director with this name.
  • A named disk is available in the Cloud director with this name.
  • A virtual machine with the same name is present in vcenter inventory.


Environment

VMware Cloud Director 10.x

Cause

This issue occurs when there is a virtual machine in vCenter with the same name as the named disk in Cloud director.

 

Resolution

To resolve the issue, remove and re-register the virtual machine from the vCenter inventory.

Please refer Remove and Reregister VMs and VM Templates or KB1006160 on how to remove and re-register the VM in vCenter.