"The name '<VM name>' already exists." error when reattaching a disk after expansion.
search cancel

"The name '<VM name>' already exists." error when reattaching a disk after expansion.

book

Article ID: 325650

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Reattaching a disk to the virtual machine fails with the error:

[UUID ] null - The name '<VM name>' already exists.

  • There is no VM present in the Cloud director with this name.
  • A named disk is available in the Cloud director with this name.
  • A virtual machine with the same name is present in vcenter inventory.


Environment

VMware Cloud Director 10.x

Cause

This issue occurs when there is a virtual machine in vcenter with the same name as the named disk in Cloud director.

 

Resolution

To resolve the issue, remove and re-register the virtual machine from the vcenter inventory.

Please refer Remove and Reregister VMs and VM Templates or KB1006160 on how to remove and re-register the VM in vcenter.