Random "HTTP 400 Bad Request" error when using VM Console and VMware Remote Console (VMRC) post upgrade to Cloud Director 10.4.x
search cancel

Random "HTTP 400 Bad Request" error when using VM Console and VMware Remote Console (VMRC) post upgrade to Cloud Director 10.4.x

book

Article ID: 325639

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Web Console and VMRC Consoles randomly fail to open.
  • A messages stating "Connection Error" is observed in the VMRC.
  • When inspecting VM Console network traffic in a Web Browsers Developer Mode screen, you observe a HTTP 400 response.
  • Upon inspection of the MKS Ticket, it's seen that it contains two slash "//" characters in a row like this example:

/443;cst-ks5Ou+YiQvB8pQEK3ciZPFdntw4P2BVIWD3iutOZi+9y/FQ5o+gXsTrzGiBwhmk4AOUTLazIK2W5hYuE7s0MH7jolTda5iyqt1O8N00iI86XzyuB+G1PpUTL3qmJXYODRRUAzfuJrTfo5b2n0cazwO8cOgrav0Ham1a//7J/mDpDvd2jaqWoN4aovRkA8K+QF0yaBLmYhBtYdxV3OUTJq5sv22UIPK2p5lk/7nayALsupW0Pty535lx6nO17K/OT/Udo3I5RKxKbnfs9QYlvkqVbOmPzi4t0aJevOo51cDYXTqHLJetyUrWmLeoZ0wy9-TEnpFBysGnG/fW7pkQPX5rNY9uVvtZXmpryuLTBKATYgXKYVdHLlM47cp8GHkzFjtAaJdWmGeVHjpzXjcwDXQjx9k/EFvaYH--tp-DF:65:E5:85:F2:50:68:EF:F2:A3:13:12:E2:28:30:B9:7C:19:E7:90--


Environment

VMware Cloud Director 10.x

Cause

This issue occurs due to the MKS Ticket contains a double slash // within it. The current implementation of Jetty has a behavior which no longer tolerates such malformed URLs and this leads to the disconnection.

Resolution

This is a known Issue in VMware Cloud Director 10.4.x release.

This issue is resolved in Cloud director 10.5.1,available at VMware Downloads.


Workaround:

The MKS ticket is regenerated each time a console connection is opened. Attempt to close and reopen the console until you get a successful connection. The likelihood of continuously getting a double slash // in the MKS Ticket is low.