Generating a Cloud Director log bundle hangs at "Preparing Files"
search cancel

Generating a Cloud Director log bundle hangs at "Preparing Files"

book

Article ID: 325613

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Attempting to generate a Cloud Director log bundle using the "/opt/vmware/vcloud-director/bin/vmware-vcd-support" command on a Cloud Director Cell
  • Log collection stalls at "Preparing Files"
  • Running the command "df -h" hangs
  • Running the command "sh -x /opt/vmware/vcloud-director/bin/vmware-vcd-support" shows the error:
Could not copy /opt/vmware/vcloud-director/bin/vmware-vcd-support/logs_name to the tar area


Environment

VMware Cloud Director for Service Provider 9.x
VMware Cloud Director 10.x

Cause

This issue occurs when the transfer directory, located at /opt/vmware/vcloud-director/data/transfer, has become unmounted or inaccessible from the Cloud Director Cell(s).

Resolution

To resolve the issue, the transfer directory needs to be mounted correctly on the Cloud Director Cell(s).

 


Workaround:

The issue occurs at the final stage of the log collection, so the log bundle will be generated but not copied to the transfer area. The log bundle can therefore be manually copied off the Cloud Director Cell(s).
It should be found in the directory from which the /opt/vmware/vcloud-director/bin/vmware-vcd-support command was run.


Additional Information

For more details on the transfer directory requirements see the VMware Cloud Director documentation here:
Preparing the Transfer Server Storage for the VMware Cloud Director Appliance
Preparing the Transfer Server Storage for VMware Cloud Director on Linux