Uploading or downloading an OVF in vCloud Director fails with the error: Failed to delete transfer session directory or transfer session directory does not exist
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Article ID: 325588
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
Cannot download or upload an OVF to/from vCloud Director Catalog.
Uploading or downloading an OVF fails between 6% and 98%.
The OVF takes a long time to download or upload.
After 6%, the status appears as ready.
The download/upload folder does not contain the OVF file.
In the download/upload status dialog, you see the message:
can not complete job at 6%
In thevcloud-container-debug.logfile, you see an error similar to:
53655 2013-03-29 11:58:00,096 | DEBUG | Quartz-pool-1-thread-4 | TransferSessionUtils | Transfer session: <TRANSFER_UUID>. Failed to delete transfer session directory or transfer session directory does not exist: /opt/vmware/vcloud-director/data/transfer/<TRANSFER_UUID>
Environment
VMware Cloud Director 10.5.x
Cause
This issue occurs if vCloud Director cannot perform read/write operations to the /opt/vmware/vcloud-director/data/transfer folder.
Resolution
To resolve this issue, verify that there is sufficient space in the vCloud Director virtual machine transfer cache directory's file system. If you require additional space for virtual machine imports and exports, mount an NFS volume internal to the vCloud Director virtual machine.
Also, ensure that the NFS folder is set with read and write permissions.
To check the permissions:
Log in to the vCloud Director with root credentials.
Change directory to /opt/vmware/vcloud-director/data/transfer.
Run this command to test the read and write permissions:
Each vCloud Director host virtual machine must mount this volume:
$VCLOUD_HOME/data/transfer, typically /opt/vmware/vcloud-director/data/transfer.
Note: Uploads and downloads occupy this storage for a few hours to a day and the transferred images can be large. Therefore, allocate at least several hundred gigabytes to this volume.