"Unable to remove LDAP provider. Make sure that there are no users, blocked users, or groups in the organization's current LDAP provider." error when attempting to remove the LDAP configuration from an Organization
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Article ID: 325539
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
Symptoms:
Receiving the following error when attempting to remove the LDAP configuration from an Organization:
Error: [XXX] Unable to remove LDAP provider. Make sure that there are no users, blocked users, or groups in the organization's current LDAP provider.
All LDAP Users and Groups have been deleted from the Organization and none are visible in the Tenant portal.
Attempting to re-add an LDAP user using another Identity Provider such as SAML fails with an error:
The VMware Cloud Director entity {username} already exists.
Environment
VMware Cloud Director 10.x
Cause
In certain scenarios stale entries may remain in the Cloud Director database referencing the LDAP user(s) which have been removed from the UI.
Resolution
To resolve this issue, please open a Support Request with VMware Technical Support and reference this KB article.
Database modifications may be required to resolve this issue and will require VMware Technical Support assistance.