VMware Failed to disconnect error when performaing migration from NSX-T Data Center to Cloud Director
search cancel

VMware Failed to disconnect error when performaing migration from NSX-T Data Center to Cloud Director

book

Article ID: 325529

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • Using VMware NSX Migration for VMware Cloud Director to migrate from NSX Data Center for vSphere to NSX-T Data Center in a VMware Cloud Director environment.
  • During migration the following error is seen in the VMware NSX Migration for VMware Cloud Director logs, <INSTALL_DIR>\logs\<VCD_URL>\Migration\<ORG_NAME>-VCD-NSX-Migrator-Main-DD-MM-YYYY-HH-MM-SS.log:

[connectionpool]:[_make_request]:452 [DEBUG] [<ORGVDC_NAME>] | https://<VCD_URL>:<port> "PUT /cloudapi/1.0.0/orgVdcNetworks/urn:vcloud:network:<NETWORK_UUID> HTTP/1.1" 400 None
[vcdOperations]:[disconnectSourceOrgVDCNetwork]:<port> [DEBUG] [<ORGVDC_NAME>] | Failed to disconnect Source Org VDC Network Network due to error.
[vcdOperations]:[configureTargetVDC]:3495 [ERROR] [<ORGVDC_NAME>] | Traceback (most recent call last):
 File "src\core\vcd\vcdOperations.py", line 3415, in configureTargetVDC
 File "src\core\vcd\vcdValidations.py", line 150, in wrapped
 File "src\core\vcd\vcdValidations.py", line 90, in inner
 File "src\core\vcd\vcdValidations.py", line 80, in inner
 File "src\core\vcd\vcdOperations.py", line 1433, in disconnectSourceOrgVDCNetwork
 File "src\core\vcd\vcdOperations.py", line 1427, in disconnectSourceOrgVDCNetwork
Exception: Failed to disconnect Org VDC Networks ['<NETWORK_NAME>']

  • In the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log, entries as below are logged:

| ERROR | pool-jetty-48595     | OrgVdcNetworkManagerImpl    | Cannot update org vdc network <NETWORK_NAME>, it was not properly created | requestId=<REQUEST_UUID>,request=PUT https://<VCD_URL>/cloudapi/1.0.0/orgVdcNetworks/urn:vcloud:network:<NETWORK_UUID>

 

Environment

VMware Cloud Director 10.x

Cause

This error can occur if the Organization VDC network is (in a disabled state ) or if there is an issue with the network not being created correctly.

Resolution

To resolve this issue, please open a Support Request with VMware Technical Support and reference this KB article.
Database modifications may be required to resolve this issue and will require VMware Technical Support assistance.