"The address ##.##.##.## did not belong to any known host" alert when an Org VDC Network's DNS entry contains an extra space character
search cancel

"The address ##.##.##.## did not belong to any known host" alert when an Org VDC Network's DNS entry contains an extra space character

book

Article ID: 325514

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:

  • Browsing a vApp or a VM on the Cloud Director Tenant portal shows an alert as below:
"The address ##.##.##.## did not belong to any known host"
  • No actions are allowed for the vApp and the VMs affected.
  • The IP address in the alert is a DNS server IP.

Environment

VMware Cloud Director 10.x

Cause

This issue can occur if an Organization VDC Network's DNS entry contains an extra space character (it could be present on the end or beginning).

Resolution

This matter is resolved in Cloud Director 10.6 which is available for download on the Broadcom Support portal. Extra validation in this latest release does not allow the input to be saved.
 
To resolve the matter in earlier releases, edit the settings of the Organization VDC Network and remove the additional space from the DNS entry as below:
  1. Connect to the Cloud Director Provider or Tenant portal and login with a user who has sufficient rights to edit Organization VDC Networks. For example as a System Administrator or an Organization Administrator.
  2. Navigate to the Organization VDC where the impacted vApps/VMs are located.
  3. Navigate to Networking, Networks and select the Organization VDC Network associated with the impacted vApps/VMs.
  4. Select IP Management, Static IP Pools and in the DNS section select EDIT.
  5. Remove any additional spaces in the DNS entries and SAVE the changes. In particular remove spaces from any DNS server entries with an IP corresponding to the address in the error message.
  6. Open the vApps/VMs connected to this Organization VDC Network in the Cloud Director UI and confirm they now open without issue.

Note: If it's not possible to modify the setting in the UI then open a support request and make reference to this SR for assistance.

Additional Information