Provider VDC backed by a Supervisor Cluster does not show the blue Kubernetes Icon and default Provider VDC Kubernetes Policy is not created
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Article ID: 325511
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
A vCenter Server 7.0 or later instance enabled for vSphere with VMware Tanzu functionality has been added to VMware Cloud Director.
A Provider VDC backed by an ESXi cluster which is enabled as a Supervisor Cluster in vSphere has been created in Cloud Director.
In the Cloud Director Provider UI under Resources > Cloud Resources > Provider VDCs, the Provider VDC does not show the blue Kubernetes icon which would show that it supports Kubernetes.
No default Provider VDC Kubernetes Policy is present in the Provider VDC under Policies > Kubernetes.
After performing a Reconnect on a vCenter from Cloud Director the Provider VDC stops showing the blue Kubernetes icon which would show that it supports Kubernetes.
Environment
VMware Cloud Director 10.x
Cause
This issue can occur if the user account used by Cloud Director to connect to vCenter has issues collecting details on the Namespaces resource pool created under the ESXi cluster which is enabled as a Supervisor Cluster in vSphere. Cloud Director can only mark the Provider VDC as supporting Kubernetes if it can see this Namespaces resource pool and store its details in the Cloud Director database.
Resolution
Open the Cloud Director Provider UI as a System Administrator and navigate to Resources > Infrastructure Resources > vCenter Server Instances.
Click on the name of the vCenter which backs the Provider VDC to open its details.
Under General > vCenter Server Info note the Username used by Cloud Director to connect to vCenter.
Open the vSphere UI and navigate to Hosts and Clusters.
Expand the ESXi cluster which is enabled as a Supervisor Cluster that backs the Provider VDC.
Confirm that a Namespaces resource pool is present.
Navigate to Administration > Single Sign On > Users and Groups > Groups and open the Administrators group.
Click Add Members and add the user that Cloud Director uses to connect to vCenter as a member, this is the Username found in step 3. above.
Return to the Cloud Director Provider UI the Resources > Infrastructure Resources > vCenter Server Instances page.
Click the radio button beside the vCenter which backs the Provider VDC and click Reconnect to reset the connection.
After the reconnect operation completes wait 3-5 minutes for Cloud Director to resync the vCenter inventory.
Navigate to Resources > Cloud Resources > Provider VDCs and confirm that the Provider VDC now shows the blue Kubernetes icon.
Click the name of the Provider VDC and confirm that a default Provider VDC Kubernetes Policy is present under Policies > Kubernetes.