SAML metadata does not update when regenerating an expired SAML certificate for an Organization in Cloud Director 10.3
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Article ID: 325494
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Updated On:
Products
VMware Cloud Director
Issue/Introduction
Symptoms:
SAML metadata does not regenerate when updating the SAML certificate for an Organization in Cloud Director 10.3.
When regenerating an expired SAML certificate, it appears to update but then reverts back to the original date when clicking Save.
If a user edits the SAML configuration for an Organization and regenerates the SAML Service Provider certificate, when updating the changes the certificate date does not get updated.
Environment
VMware Cloud Director 10.x
Cause
This defect is caused by the Save button reverting the settings back to the old keys and certificates.
Resolution
This is a known issue affecting Cloud Director 10.3. The issue is resolved in Cloud Director 10.3.3, available at Broadcom Downloads
If you cannot upgrade to Cloud Director 10.3.3 or above, please use the workaround specified in the Workaround section.
Workaround:
Open the Provider portal of Cloud Director and navigate to the Resources > Cloud Resources > Organizations tab.
Click on the name of the Organization to be updated.
Click on Identity Providers > SAML.
Note the Service Provider > Certificate Expiration date shown.
Click Edit.
Click Regenerate.
Click OK, but do not click Save.
The Certificate Expiration date in the UI will have changed.
Click Discard.
The Service Provider > Certificate Expiration date gets updated to the required new date.
Additional Information
Impact/Risks: The expired SAML certificate does not regenerate and update with a new expiry date in the UI