Error: "A specified parameter was not correct: parent" error when trying to power on a virtual machine in Cloud Director
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Error: "A specified parameter was not correct: parent" error when trying to power on a virtual machine in Cloud Director

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Article ID: 325484

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Powering on a virtual machine(VM) in Cloud Director UI shows the error:

    [ ########-####-####-####-############ ] The operation could not be performed because the argument is invalid. A specified parameter was not correct: parent
     - A specified parameter was not correct: parent

  • From the vCenter, at the time of the issue, operation to move the VM to a resource pool is carried out which fails with the error:

    A specified parameter was not correct: parent

  • Saving the settings of the VM returns the following error without any changes being applied: 

    [ ########-####-####-####-############ ] Internal Server Error




Environment

VMware Cloud Director(VCD)

Cause

This issue can occur if

  • There are invalid resource pool mappings in the Cloud Director for the affected VM and the Organization VDC(OVDC) where it is located.
  • The backing VM was cloned in vCenter(VC) by a user, the VCD VM is now pointing to the cloned VC VM.

Resolution

To resolve the issue:

    1. From vCenter UI verify that the affected VM is located in the correct resource pool for the OVDC.
    2. Verify if the original VM was cloned in VC directly.
      1. Ensure it is safe to power off the cloned VM, remove it from VC inventory keeping only the original VM in VC. 
      2. Follow the articles listed in Step 4 to remove the affected VM is cleanly removed from VCD management and re-import to VCD.
    3. If the affected VM is located in the correct resource pool or the VC VM is not cloned, the inconsistency might be in the Cloud Director database. For assistance, contact technical support and note this Knowledge Article ID (325484) in the problem description. For more information, see How to Submit a Support Request.
    4. Alternatively the affected VM can be removed from VCD/VC and re-add/re-import to VC/VCD to eliminate the inconsistency.