Management cluster fails to deploy on Telco Cloud Automation (TCA) 3.0 due to "panic: interface conversion: interface {} is nil, not string" error
search cancel

Management cluster fails to deploy on Telco Cloud Automation (TCA) 3.0 due to "panic: interface conversion: interface {} is nil, not string" error

book

Article ID: 325387

calendar_today

Updated On:

Products

VMware VMware Telco Cloud Automation

Issue/Introduction

Symptoms:

TCA UI Error:

E_FAILED_TO_CREATE_CLUSTER    Unable to create cluster {clusterName}. Reason: Bootstrapperd Process/KBS Pod RestartedLogin to TCA-CP or Collect TechSupport Bundle of TCA-CP for the logs.

kbs-tkg/xxx-operator/y.log:

[Info-adapter] : Management cluster created successful
panic: interface conversion: interface {} is nil, not string


Environment

VMware Telco Cloud Automation 3.0

Cause

In TCA 3.0, when an airgap server is added to TCA via Partner Systems, the CA certificate is optional if the airgap server is deployed with a public signed certificate (commercial certificate).

When deploying management cluster in this environment, the management cluster creation succeeds on the TKG side but eventually fails in TCA due to the airgap cert configuration value being null.

Resolution

Addressed in TCA 3.1.

Workaround:
  1. Log into the TCA UI.
  2. Navigate to Infrastructure > Partner Systems.
  3. Find the airgap server from the list and select the Edit option actions button (3 dots).
  4. Provide the CA certificate used to sign the certificates for airgap server in the box available for CA certificate. This is required even if a commercially signed certificate is being used.
  5. Click on FINISH to complete the airgap server registration.
  6. Retry the management cluster creation that had failed before.
  7. Verify that the cluster creation is successful and that the Connection Status for airgap server goes to enabled from Partner Systems tab.


Additional Information

Impact/Risks:
Impacts TCA 3.0.