Global Search UI Patch to Resolve Duplicate Harbor Add-on in Telco Cloud Automation (TCA)
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Global Search UI Patch to Resolve Duplicate Harbor Add-on in Telco Cloud Automation (TCA)

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Article ID: 325361

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Updated On:

Products

VMware VMware Telco Cloud Automation

Issue/Introduction

Symptoms:

When using the global search feature located in the VIM Associations page of the TCA UI, a duplicate Harbor add-on can be added to workload clusters causing node pool creations to be stuck in a processing state. This in turn can cause workload cluster delete operations to fail.

 


Environment

VMware Telco Cloud Automation 1.x
VMware Telco Cloud Automation 2.3
VMware Telco Cloud Automation 2.0.1
VMware Telco Cloud Automation 2.1
VMware Telco Cloud Automation 2.0
VMware Telco Cloud Automation 2.1.1
VMware Telco Cloud Automation 2.2

Cause

An internal issue with the global search option in the VIM Associations page causes a duplicate Harbor add-on to be created.

Resolution

This issue will be addressed in Telco Cloud Automation 3.0.

Workaround:
The following procedure applies a patch that resolves this issue. The patch is applied on the TCA Manager and no service restart is required. Simply reload the web browser.

1. Download the attached KB92034_nfv.tar  patch and copy it to the /tmp directory of the TCA Manager.
2. SSH into the TCA Manager as an admin user.
3. Change directory into the web directory by executing the following command: 
    cd /opt/vmware/web
4. Backup the hcx-ui directory by executing the following command:
    tar -czpf hcx-ui-backup.tgz hcx-ui
5. Change directory to hcx-ui by executing the following command:
    cd hcx-ui
6. Extract the new patch by executing the following command:
    tar -xzpf /tmp/KB92034_nfv.tar.tz
7. Reload the TCA Manager UI. It is recommended to log out and then log back in to ensure a complete reload.


Additional Information

Impact/Risks:
Impacts versions 1.X and  2.X of Telco Cloud Automation.

Attachments

KB92034_nfv.tar get_app