Servers missing from Performance Center after integrating with Spectrum
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Servers missing from Performance Center after integrating with Spectrum

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Article ID: 32534

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Updated On:

Products

CA Performance Management - Usage and Administration CA Spectrum DX NetOps

Issue/Introduction

After integrating DX NetOps Performance Management and Spectrum some device models are not synchronized to the Portal inventory.

We also see the models in Spectrum still have a zero (0) value for the CAPC_Item_Id (attribute ID xxx) attribute on the affected models.

We see this for some virtual servers discovered and managed by Spectrum VHM functionality.

We also see this for other device models like Routers and Switches.

After turning on debug in Spectrum for Performance Center Integration Synch the following message is seen in the Spectrum tomcat log. The message references the device using it's Model_Handle attribute value (attribute ID 0x129fa).

Oct 08, 2024 13:37:42.724 (http-nio-80-exec-14) (NetqosSyncLog) - (TRACE) - Device 0x1bd23dc is not active yet, added to postponed list for later processing

Environment

All supported DX NetOps Performance Management and Spectrum releases

Cause

Device model did not successfully complete activation post discovery. It's Model_State attribute (attribute ID 0x1007c) shows a value of "Error(3).

Resolution

In Spectrum the Model_State (0x1007c) must be set to Active (1). If it is not, it is added to the postponed list for later processing.

To resolve this depends on device type. Follows these steps.

  1. Choose a device type, follow the steps to get Model_State to be Active(1).
    1. Devices not managed by Virtual Host Manager. There are two choices to resolve this.
      • Delete and rediscover the device.
        • When the modeling completed confirm Model_State shows Active(1) for the device model.
      • Run a Reconfigure Model (right click on device and choose Reconfiguration->Reconfigure Model.
        • When the Reconfigure Model action is completed confirm Model_State shows Active(1) for the device model.
    2. Devices managed by VHM. To change Model_State of the virtual server discovered by VHM in Spectrum complete the following:
      1. Confirm the device is up and accessible
      2. If the device was discovered by virtual host manager change the model attribute EditModeMask (attribute ID 0x130cc) from 244 to 0.
        • This enables the ability to delete the device discovered/managed by VHM.
      3. Delete the device.
      4. After deleting the device VHM polls the VCAIM. Once it determines there is a missing or new VM not in Spectrum inventory, it remodels it.
      5. When the modeling is completed confirm Model_State shows Active(1) for the model.
    3. Once the problems models have Model_State=Active(1) ensure they are added to the correct IP Domain Global Collection (GC) in Spectrum for synchronization to Portal Inventory.

After the Spectrum Data Source (DS) and the Portal Global Synchronization cycles have passed to sync the new device to inventory it should show from Spectrum.

Final confirmation for successful device sync between Spectrum and Portal is the CAPC_Item_Id attribute (attribute ID 0x13214). It should be populated with the Portal Item ID it's been assigned for Portal Inventory. A value of zero indicates it has not successfully synced through the integration.