[VMC] Unable to activate Windows Server: This version of windows doesn't have licensing key attached
search cancel

[VMC] Unable to activate Windows Server: This version of windows doesn't have licensing key attached

book

Article ID: 325018

calendar_today

Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

After running the activation script (activation.ps1) to activate Microsoft Windows Server, the following error message is seen:

This version of windows doesn't have licensing key attached
Please check in VMC console if your cluster is activated and supported version of windows is getting used.

Environment

VMC on AWS

Cause

The most common causes for seeing this error message are:

  • The version of Microsoft Windows Server being activated is not available in the cluster. 
  • The host where the virtual machine is running is missing the license for the version of Microsoft Windows Server being activated. 
  • VMware Tools is required to be re-installed or upgraded. 

Resolution

To resolve this issue, work through the below steps to attempt the activation again:

  1. Reboot the virtual machine and attempt the activation again. 
  2. Migrate the virtual machine to another host in the cluster and attempt the activation again. 
  3. Re-install VMware Tools on the virtual machine and attempt the activation after reboot. 

The following message will be seen if the above steps resolve the issue: Successfully activated the windows instance.
If activation is not successful after completing the above steps, open a ticket with the VMC on AWS Global Support team: Get Support

Note: If activating any other version of Microsoft Windows Server other than Microsoft Windows Server 2019 Datacenter, it will need to be verified that the cluster has licenses available for other versions of Windows Server. Open a ticket with the VMC on AWS Global Support team and ask to have the available Microsoft Windows Server versions verified for the cluster. 

Additional Information

Microsoft Product Licenses in VMware Cloud on AWS