Log collection stuck in "collecting logs" after vRA appliance reboot
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Log collection stuck in "collecting logs" after vRA appliance reboot

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Article ID: 324878

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
Log bundle collection appears stuck in "collecting logs" indefinitely after the vRealize Automation appliance is reboot.

Environment

VMware vRealize Automation 7.6.x
VMware vRealize Automation 7.x

Cause

  • This issue might occur if the VA was rebooted while the log bundle generation was running. This would leave the database in an inconsistent state. 
  • The collecting logs message appears due to the fact that there are some commands left in the Processing state.
  • Alternatively, this issue might occur when VA's are in non-UTC timezone. For more information, see Do Not Change the vRealize Automation Time Zone.
Note: Log bundle collection could be just slow due to the existence of large files (.hprof or .sql dumps) in the logs partition

Resolution

This is a known issue affecting VMware vRealize Automation versions 7.5 and 7.6. 

Currently, there is no resolution. 

Note: This issue is NOT present on 8.x versions as the logging mechanisms are different.

Workaround:
To work around this issue, update the log-bundle commands that are in PROCESSING or QUEUED state to FAILED or COMPLETED. This will unblock the UI.
  1. Open an SSH session to the primary appliance.
  2. Connect to the Postgres database by running the commands:
su postgres
psql -d vcac
  1. Run the following queries:
update cluster_commands set status = 'FAILED' where type = 'log-bundle' and status='PROCESSING';
update cluster_commands set status = 'FAILED' where type = 'archive-bundles' and status='QUEUED';
  1. Ensure to set the VA timezone on all VAs to Etc/UTC from the VAMI settings.
  2. Ensure you do not have any large files, such as .hprof or .sql dumps in the logs partition to reduce the log bundle generation times.