This article clarifies the behavior of vSphere HA's response to All Paths Down (APD) events.
To view the APD Failure Response section events from vCenter UI, navigate to:
Hosts and Cluster > <click on a cluster of choice> > Configure tab > vSphere Availability >
click Edit > Expand Datastore with APD item
VMware vSphere
Currently, you have four options to choose:
When an APD occurs for a datastore on a host, if either "Conservative" OR "Aggressive" options are selected, vSphere HA will first try to find a host where it can be powered on. If it can find one, the VM is terminated and attempted to power on at the selected host.
If a suitable host cannot be found is when there is a difference of behavior between "Conservative" and "Aggressive".The behavior itself has not changed since 7.0 when compared to previous releases like 6.5 or 6.7.