Connection between VMware vRealize Automation and embedded vRealize Orchestrator fails with the error: Cannot connect to Orchestrator server
search cancel

Connection between VMware vRealize Automation and embedded vRealize Orchestrator fails with the error: Cannot connect to Orchestrator server

book

Article ID: 324804

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Testing the connection between VMware vRealize Automation and embedded vRealize Orchestrator fails.
  • You see the error:

    Cannot connect to Orchestrator server
     
  • The error appears sporadically.
  • In the /var/log/vmware/vcac/catalina.out file, you see an entry similar to:

    [Error code: 85020 ] - [Error Msg: 85020-Unable to find default vCO endpoint in the Registry. Contact your System Administrator.]


Environment

VMware vRealize Automation 6.2.x

Cause

This issue occurs when the VMware vRealize Orchestrator endpoint becomes unregistered from VMware vRealize Automation.

Resolution

This is a known issue affecting VMware vRealize Automation 6.2.x.

Currently, there is no resolution.

To work around this issue, re-register the Orchestrator service.

To re-register the Orchestrator service:
  1. Log in to the vRealize Appliance Linux console as the root user.
  2. Run the command:

    Note: This command will reset the connection with the vRealize Automation or vRealize Orchestrator appliance so ensure there are no workflows running.

    vcac-vami vco-service-reconfigure
     
  3. Log out and test your vRealize Orchestrator connection.


Additional Information


VMware vRealize Automation 6.2.1 と組み込みの vRealize Orchestrator の接続が次のエラーで失敗する:Orchestrator サーバに接続できません