MSP Task % Complete mismatch: In Clarity it shows 100%, while in MSP it shows 99%

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Article ID: 32475

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

  • In Microsoft Project (MSP), % Complete is incorrectly showing as 99% for one or more tasks, while in Clarity PPM it is showing as 100%.
  • Another symptom reported can be that the % complete is being calculated based on on start/finish dates, but it's expected the % Complete should be able to be set manually. 

Cause

  • This issue can happen if the MSP Option 'Updating Task status updates resource status' is checked.
  • It is required to have this unchecked when integrating MSP with Clarity PPM.

Environment

Release: All Supported Releases
Component: Clarity PPM MSP

Resolution

Uncheck 'Updating Task status updates resource status'  using the below steps:

  1. Open the project in MSP
  2. Go to File, Options
  3. Select Schedule
  4. Scroll down to the Calculation options for this project section
  5. Ensure the setting under 'Updating Task status updates resource status' in unchecked. If not, uncheck it and click OK.


Notes:

  • This change will also need to be set for all projects going forward to prevent this issue.
    • To do this:
      • Under the Calculation options for this project, select 'All New Projects'
      • Uncheck 'Updating Task status updates resource status'
      • Click OK.
  • To review all required and recommended settings in MSP in working with Clarity PPM to make sure these are set correctly, see kb000010047.

Additional Information

  • Clarity PPM and MSP integration known defects - Support Technical Document Index (KB: 15956)

  • Clarity PPM and MSP integration - List of knowledge documents (KB: 71385)

  • List of Clarity PPM KB articles related to issues opening projects in MSP  (KB: 138671)

  • See KB: 141061 for tips on how to optimize use of Self Service for Clarity PPM