Re-registering a plug-in after un-register does not appear in the vSphere Client
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Re-registering a plug-in after un-register does not appear in the vSphere Client

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Article ID: 324719

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • When you re-register a plug-in after un-register, the plug-in does not appear in the vSphere Client.
  • After un-registering a plug-in, you still see the un-registered plug-in in the vSphere Client.


Environment

VMWare SDK - TAP Program

Cause

This issue occurs because the Virgo server cache is not updated automatically.

Resolution

To resolve this issue, restart the vSphere Client service.

Additional Information

Uninstalling the plug-in
 
This test verifies that your vSphere Web Client plug-in uninstalls successfully.

Note: This test requires one vCenter Server with your vSphere Web Client plug-in installed.
  1. Uninstall the vSphere Web Client plug-in.
  2. Restart the vSphere Client service.
  3. Log in to the vSphere Client using administrator credentials.
  4. Verify that the plug-in is unregistered:
    1. Go to https://<vCenter Server IP address>/mob and log in using the SSO credentials.
    2. Go to Content > ExtensionManager.
    3. Verify that your plug-in ID is not listed in the Properties table.

Re-registering the plug-in

This test verifies that the vSphere Web Client plug-in is re-registered successfully.
  1. Register the vSphere Web Client plug-in.
  2. Restart the vSphere Client service.
  3. Log in to the vSphere Client using administrator credentials.
  4. Verify that the plug-in is registered:
    1. Go to https://<vCenter Server IP address>/mob and log in using the SSO credentials.
    2. Go to Content > ExtensionManager.
    3. Verify that your plug-in ID is listed in the Properties table.