Workload Domain creation or expansion fails in SDDC Manager
search cancel

Workload Domain creation or expansion fails in SDDC Manager

book

Article ID: 324660

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • Workload Domain creation or expansion fails. The failure could occur while provisioning an ESXi host or one of the management virtual machines.
  • Another Workload Domain in the same VMware Cloud Foundation rack has been deleted.
  • One or more of the management virtual machines (vCenter Server, NSX Manager, and so on) related to the deleted Workload Domain is still running in the management cluster.


Cause

This issue can occur when the Workload Domain deletion process leaves one or more management virtual machines running and the IP address assigned to that virtual machine is to be used on an ESXi host or management virtual machine in the new or expanded Workload Domain.

Resolution

This issue is resolved in VMware Cloud Foundation 2.2, available at VMware Downloads.
 
To work around this issue if you do not want to upgrade, power off the offending management virtual machines.
 
To prevent this issue to reoccur, delete the management virtual machines after they are powered off.

Note: If the offending vCenter Server appears to still be registered in the vSphere Web Client, refer to the Knowledge Base article Using the cmsso command to unregister vCenter Server from Single Sign-On (2106736).


Additional Information

Using the cmsso command to unregister vCenter Server from Single Sign-On (2106736)