Problem:
After installing 18.5 and completing all Configuration jobs we bring up the IDMS CV successfully, but our attempt to access the CV via UCFTSO Clist gives only BACK END SYSTEM IS NOT ACTIVE with no other error messages or abend codes.
Typically UCF returns abend code such as S019 or other Snnn error.
Environment:
all IDMS environments.
Cause:
In this case it was determined that the client had not properly generated their SYSTEM to include a UCF LINE and the associated PTERM/LTERM definitions.
Resolution/Workaround:
To access an IDMS CV via any UCF connection (UCFCICS, UCFTSO or UCFBATCH), the IDMS SYSTEM definition must include an ENABLED UCF LINE definition and several sets of PTERM/LTERM definitions for as many concurrent user connections as will be required.
Additional Information:
CA IDMS SYSTEM OPERATIONS GUIDE, Chapter UCF OPERATIONS, section UCF SYSTEM GENERATION STATEMENTS