App Volumes attachments fail with the folowing warning: "Waited 180 seconds attempting to locate VM with IP"
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App Volumes attachments fail with the folowing warning: "Waited 180 seconds attempting to locate VM with IP"

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Article ID: 324568

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • End users do not receive expected appstacks
  • The App Volumes Manager logs contain the following warning:
[2022-01-01 23:54:34 UTC] P4164R101046  WARN    vCenter: Waited 180 seconds attempting to locate VM with IP 10.1.10.100 - giving up on #<Thread:0x000000001b3c0058@C:/Program Files (x86)/CloudVolumes/Manager/app/models/cvo/hypervisor/vcenters_adapter.rb:804 run>


Cause

This issue can occur if the value of App Volumes manager in the agent registry is modified after computer startup. App Volumes Agent identifies managers while svservice is started by SCM(services.exe). If a post synchronization script is attempted to change the value of the managers in the registry it will fail to contact the correct App Volumes Manager. This value must be configured before computer startup.

Resolution

Do not attempt to set the App Volumes Manager server values in the agent registry post computer startup. For example, modifying the App Volumes manager server values with a post-synchronization script is not supported. If the same image is used across multiple sites different snapshots can be used to differentiate between different App Volumes Manager servers.
If the value of App Volumes Manager is not modified after startup then this error indicates a network communication issue. Perform basic network troubleshooting.

Additional Information

Impact/Risks:
App stack attachments will fail.