Networking information for an ESX/ESXi host is blank in the vSphere Client
search cancel

Networking information for an ESX/ESXi host is blank in the vSphere Client

book

Article ID: 324549

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • If you click Networking on the Configuration tab in VMware Infrastructure/vSphere Client, the screen is blank.
  • No vSwitch or NIC information displays for an ESXi/ESX host.


Environment

VMware ESXi 4.0.x Embedded
VMware ESXi 3.5.x Embedded
VMware ESXi 4.0.x Installable
VMware ESX 4.0.x
VMware ESX Server 3.5.x
VMware ESXi 3.5.x Installable

Cause

This issue may occurs if a configuration file (esx.conf) on the host becomes corrupted.

Resolution

This issue is resolved in ESX 3.5 Update 5. For more information about this version, see the ESX 3.5 Update 5 Release Notes. You can download the latest release from the VMware Download Center.
 
To work around this issue when you cannot upgrade, perform a hard reset of the system to restore normal operations. You must perform a hard reset as opposed to a normal reset to prevent the corrupted esx.conf file from updating to the tarball image. The file is written back to the image during a normal reset, which results in the corrupted version being saved
 
Caution: It is important to plan a maintenance window to power off all the virtual machines before proceeding with the procedure in this article.
 
To perform a hard reset of the ESXi/ESX host:
  • Press the Reset button on the physical box.

    OR
     
  • Unplug the power cable and wait 15 seconds.