vSwitch networking configuration is blank on an ESXi/ESX 4.x host
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vSwitch networking configuration is blank on an ESXi/ESX 4.x host

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Article ID: 324545

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • In vSphere Client, when you click the Networking link under the Configuration tab, the vSwitch configuration is blank.
  • vSphere Client does not display configured vSwitches.
  • Running the esxcfg-vswitch -l command fails with the error:

    Failed to read advanced option subtree UserVars: Error interacting with configuration file
    /etc/vmware/esx.conf: Unlock of ConfigFileLocker failed : Error interacting with configuration file /etc/vmware/esx.conf: I am being asked to delete a .LOCK file that I'm not sure is mine. This is a bad thing and I am going to fail. Lock should be released by (0)

     
  • The hostd.log file (located at /var/log/vmware/hostd.log) contains entries similar to:

    VmkCtl call to get system vmdk files failed: Error interacting with configuration file /etc/vmware/esx.conf: Unlock of ConfigFileLocker failed : Error interacting with configuration file /etc/vmware/esx.conf: I am being asked to delete a .LOCK file that I'm not sure is mine. This is a bad thing and I am going to fail. Lock should be released by (0)
    [14:22:09.519 49B40B90 verbose 'App'] Looking up object with name = "firewallSystem" failed.
    [14:22:09.610 49B40B90 verbose 'NetConfigProvider'] FetchFn: List of pnics opted out
    [14:22:09.618 49B40B90 info 'HostsvcPlugin'] Failed to read advanced option subtree UserVars: Error interacting with configuration file /etc/vmware/esx.conf: Unlock of ConfigFileLocker failed : Error interacting with configuration file /etc/vmware/esx.conf: I am being asked to delete a .LOCK file that I'm not sure is mine. This is a bad thing and I am going to fail. Lock should be released by (0)


Environment

VMware ESXi 4.0.x Installable
VMware ESXi 4.1.x Embedded
VMware ESX 4.1.x
VMware ESXi 4.1.x Installable
VMware ESX 4.0.x
VMware ESXi 4.0.x Embedded

Cause

This issue occurs when the esx.conf file does not update correctly.

Resolution

This issue is resolved in ESXi 4.1 Update 3. For more information, see the VMware ESXi 4.1 Update 3 Release Notes.

To work around this issue without upgrading, restart the management services.
 
To restart the management services:
  1. Log in to the local Tech Support Mode console of the ESXi/ESX host. For more information, see Unable to connect to an ESX host using Secure Shell (SSH) (1003807) or Using Tech Support Mode in ESXi 4.1 (1017910).
  2. Restart the management services on the host using the command:
     
    • ESXi:

      services.sh restart
       
    • ESX:

      service mgmt-vmware restart

    Note: Wait for the command to complete. It can take several minutes and further errors about esx.conf may appear.

    You see output similar to:

    Running ServiceName restart
    Error running operation: Error interacting with configuration file /etc/vmware/esx.conf: Failed attempting to lock file. Another process has locked the file for more than 20 seconds. The process holding the lock is (0). This operation will complete if it is run again after the lock is released.

     
  3. Connect to vCenter Server using vSphere Client.
  4. Right-click the ESXi/ESX host and click Connect.

    Note: Connecting may fail once. If so, try a second time.
     
  5. Check networking configuration. Click the Configuration tab, then click Networking.

    Caution: vMotion might be disabled after performing these steps. Re-enable vMotion for the VMkernel interfaces on the vMotion network.


Additional Information


Restarting the Management agents in ESXi
Unable to connect to an ESX host using Secure Shell (SSH)
Using Tech Support Mode in ESXi 4.1, ESXi 5.x, and ESXi 6.x
Location of ESXi 3.5-4.1 log files