Cannot convert to the Enhanced LACP support
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Cannot convert to the Enhanced LACP support

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Article ID: 324524

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • After upgrading to vSphere Distributed Switch 5.5, you are unable to convert to the enhanced Link Aggregation Control Protocol (LACP) mode from an existing LACP configuration.
  • Converting to the enhanced LCAP support fails.


Environment

VMware vCenter Server 5.5.x
VMware vSphere ESXi 5.5

Cause

Converting to the enhanced LACP support from an existing LACP configuration includes several tasks for reconfiguring the Distributed Switch. The conversion may fail if there was a concurrent reconfiguration of the Distributed Switch during the conversion. For example, physical NICs from the hosts have been reassigned to different uplinks or the teaming and failover configuration of the distributed port groups is changed.
 
This issue may also occur if some of the hosts have disconnected during the conversion.

Resolution

When the conversion to the enhanced LACP support fails, it completes only partially. You must check the configuration of the distributed switch and the participating hosts to identify the objects with incomplete LACP configuration and then complete the LACP configuration manually for these objects.
 
To resolve this issue and to complete the LACP configuration manually:
  1. Check the LACP configuration of the Distributed Switch and ensure a newly created LAG is present on the Distributed Switch:
    1. In the Distributed Switch, Click Manage and then click Settings.
    2. Select LACP.
    3. If there is no LAG created, click New Link Aggregation Group.
    4. Set the LAG name and number of ports. You can assign physical NICs to each of the LAG ports, which have the same function as standalone uplinks.
    5. Set the LACP mode. If all ports on the corresponding LACP port channel on the physical switch are active, you can leave the LACP mode of the LAG to Passive and vice versa.
    6. Select a load balancing policy for the LAG. All load balancing policies of LACP are supported.
    7. Set the VLAN and NetFlow policies, if applicable.
       
  2. Check if there is an intermediate LACP teaming configuration on the distributed port groups. The newly created LAG must be set to standby to migrate physical NICs to the LAG without dropping connectivity:
    1. Navigate to a distributed port group.
    2. In the Actions menu, click Edit Settings.
    3. Select Teaming and failover.
    4. If there is no LAG in the standby list, move the newly created LAG to that list.

      Note: If you do not want to use a LAG to back up the traffic for all distributed port groups, revert the teaming and failover configuration to a state where standalone uplinks are active and the LAG is unused.
       
  3. Check the topology of the distributed switch and migrate the standalone uplinks to the LAG ports:
    1. In the Distributed Switch, Click Manage and then click Topology. All physical NICs must be assigned to the LAG ports.
    2. If there are any NICs that remain assigned to the LAG ports, reassign those NICs to the LAG ports.

      Note: The LAG must remain in standby in the teaming and failover order of the distributed port groups while you reassign physical NICs to the LAG ports.


Additional Information

Ensure to validate the LACP teaming and failover configuration for each of the applicable distributed port groups. Each port group should have only the new LAG as active and should have no adapters in standby. All standalone uplinks not associated with a LAG must be listed as Unused. Limitations of LACP in VMware vSphere 5.5
Converting to Enhanced LACP Support on a vSphere Distributed Switch in the vSphere Web Client
Differences in LACP support in vSphere Distributed Switch 5.5 and 5.1